Ubuntu 18.04 + Java 10 cannot install

DbSchema Issues
Post Reply
Tecktron
Posts: 3
Joined: Tue Jun 05, 2018 6:41 am

Ubuntu 18.04 + Java 10 cannot install

Post by Tecktron » Tue Jun 05, 2018 1:21 pm

I have a fresh install of Ubuntu 18.04 LTS. I cannot get Dbschema installed.
I have installed the latest Oracle Java 10 and removed the included OpenJDK, since OpenJDK failed (in exactly the same way). Yes, I have tried both with exactly the same results.
Here is the message I get when I try to run Dbschema from deb installed /opt/Dbschema or if I try and run the bash script installer:
No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 1.8.0_71 and at most 1.8.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.
I added INSTALL4J_JAVA_HOME=$JAVA_HOME (and have tried $JAVA_HOME/bin) in my /etc/profile where I set JAVA_HOME to point to my java install, but it didn't help. Yes I reloaded, rebooted even and it shows up in printenv so it's 100% there plus I can build and run java code and apps.
I tried running this process as sudo as well, same message.

Here's my java -version output.
java version "10.0.1" 2018-04-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)
What do I need to do in order to run this?

Cheers

support
Posts: 85
Joined: Tue Dec 01, 2015 8:44 am

Re: Ubuntu 18.04 + Java 10 cannot install

Post by support » Wed Jun 06, 2018 8:09 am

Please try to install Oracle Java 8. We are not yet fully tested against Java10, as they removed JavaFx from their installation. We are working on this. If you don't get DbSchema 8 running, please use DbSchema 7.6 from website, this works with Swing.

Tecktron
Posts: 3
Joined: Tue Jun 05, 2018 6:41 am

Re: Ubuntu 18.04 + Java 10 cannot install

Post by Tecktron » Mon Aug 06, 2018 5:49 pm

I tried to get this to work on Oracle Java 8 but it fails and tells me that I need at least v9 (maybe you should remove the version check since Oracle removed JavaFX from the JDK package starting v9 and the OpenJFX package now only works with openJDK8?).
So as of right now the latest version no longer works on Ubuntu given the current java environment (Oracle really f'd up here IMO).
For now, I've downgraded to v8.0.3 as it works with the openjdk-8 installed by openjfx.

For anybody else experiencing this and needs to downgrade, I found the deb file here: https://www.dbschema.com/download/DbSchema_linux_8_0_3.deb

to remove the current package (in case you upgraded) you can remove the current using this:

Code: Select all

sudo dpkg --remove Dbschema
Now you can install v8.0.3 and still use what you're paying for (as long as you don't need a bugfix in a newer version).

@support: I'm really interested how your team is testing the newer version on Debian/Ubuntu systems, if they have steps on how they are getting their setup working, can you please provide?

support
Posts: 85
Joined: Tue Dec 01, 2015 8:44 am

Re: Ubuntu 18.04 + Java 10 cannot install

Post by support » Mon Aug 13, 2018 10:32 am

With DbSchema 8.0.6 we are fully migrated to Java 10 or 9. Please upgrade Java.

Post Reply