trouble connecting to DB2

Db2 - related issues
Post Reply
Posts: 2
Joined: Sat Sep 06, 2014 3:16 am

trouble connecting to DB2

Post by paultaylor » Sat Sep 06, 2014 3:41 am

I've used DbSchema for many years with MySQL & PostgreSQL.

Recently I tried to reverse engineer a DB2 database - unsuccessfully.
The database base is on an AS/400 or iSeries. I have downloaded the open source JT400.jar and successfully connected to the database using SquirrelSQL.
When configuring DbSchema to connect to the same DB, I used the same driver and selected the DB2z/OS option.
I get errors reading DB2 system tables, so I altered the DbSchema reverse engineer SQL statements to refer to QSYS2 instead of SYSIBM. This got me thru most of the queries until the very end, when it displays an error 'cannot read REMARKS column'.
I can't get past this error.

So, I downloaded and installed DB2 LUW on my employer owned PC. I am not an administrator of this PC, but I do have application install rights. Because of this, I installed DB2 LUW without a userid or password. SquirrelSQL can successfully connect to this database.
Time to configure DbSchema. I selected the default DB2 driver and let DbSchema download the driver. Then completed the configuration information and left user id & password empty.
DbSchema complains that user id & password cannot be empty. If I put something in there, DbSchema advises that authentication failed.

This is very frustrating!
SquirrelSQL can connect to both databases using the same JAR drivers as DbSchema uses. DbSchema cannot.

Has anyone been able to successfully connect to DB2?
ps. I'm using DbSchema 4016.


Posts: 44
Joined: Sun Sep 28, 2014 11:35 am

Re: trouble connecting to DB2

Post by davidfrost » Wed Oct 08, 2014 4:32 pm

Hi Paul, looks like this is still unanswered. Have you found a work around to this so far?

Posts: 2
Joined: Sat Sep 06, 2014 3:16 am

Re: trouble connecting to DB2

Post by paultaylor » Wed Oct 08, 2014 8:47 pm

Still no fix for DB2.
I dumped the DB2 SQL and loaded it into PostgreSQL - because they both have schemas.

DbSchema works on PostGreSQL, but not DB2.

Posts: 1
Joined: Fri Dec 16, 2016 4:49 pm
Location: Mali

trouble connecting to DB2

Post by AndressoureMM » Wed Dec 21, 2016 4:23 am

I installed Microsoft Sql database developer edition in my server. All workstations in my network can able to connect to this database with server name. For eg my database name is IBMSERANET. All workstations can able to connect with server name only and not ip address of server. when they try to connect with ip address some error message pop ups which states that server does not allow remote connections. But no problem when connecting with the database there any solutions for this?

thank you

Posts: 1
Joined: Wed Feb 01, 2017 9:50 am

Re: trouble connecting to DB2

Post by alice123 » Wed Feb 01, 2017 9:59 am

There are lots of SQL errors can be found while accessing any DB2 database or while connection procedure. However, you can find the different SQL errors here and the solution as well to fix the issue so that you can easily connect your DB2 database and will not face any issue while connecting to DB2 database. You can know more about SQL errors and their fixes at: ... -solutions

Post Reply